It is Alive! Update: EFI Fail!!!

BBShark

Garage Monkey
Staff member
Joined
Mar 5, 2008
Messages
4,621
Location
Right here
After years of disassembly and years of (partial) reassembly, the engine was fired for the fist time yesterday. The software for the fuel injection needs to be worked out but one more dot has been connected to a running car!:beer:
 

BBShark

Garage Monkey
Staff member
Joined
Mar 5, 2008
Messages
4,621
Location
Right here
One of the penalties for taking so long to get this back together is some of the stuff I bought early on (thinking I was going to get this together next summer). One of these is the fuel injection. It's a fifteen year old product. I had to locate a laptop with a COMM port and a 3 1/2 floppy drive and Windows (no later than XP). I found that with the exception of the floppy drive.

It took me a couple of days to load the software onto the laptop and then onto the ECU. So, I still need to edit the fuel MAP to get it tuned, but it fires up. That (for me), is huge.
 

rtj

Well-known member
Joined
Nov 5, 2011
Messages
2,548
You can still buy usb floppy drives. I got one a few years ago to transfer files off an old computer.

But, it sounds like you are in business now. Must feel good to be getting ready for spring.
 

BBShark

Garage Monkey
Staff member
Joined
Mar 5, 2008
Messages
4,621
Location
Right here
EFI Fail!

So, here I am (more than) a year later. I didn't work on getting this tuned over the winter of 2020 because I didn't want to fill the garage with fumes. I did fire it back up in the summer and the spark plug wire clips on the back cylinder melted (it was 3 inches above the header tube). Then the melted material dripped onto the header tube and resulted in a small (but persistent) FIRE. That fire was hot enough that it burned the insulation off the silicone wires. I was lucky, other than the wires there mas not any damage.

Next step was to replace the burned plug wires and separators. This took a while because I was so pissed that the clips caught of fire (I think they were MSD or Accell) and I had to remake the wires because they were custom length. I fired it back up later that summer and really made absolutely no progress on getting this tuned so I basically just gave up.

Until now. My current problem is that I was using an relatively antique EFI system (Holley Commander 950 purchased ~13 years ago) . It took me months to accept the conclusion that I would never get this to work after spending LOTS of time reading stuff on the internet and months of wiring this into my car. I suppose I'm now in the final stage of grief; denial, anger, bargaining, depression, acceptance.

Been shopping for a replacement and it looks like the best (easiest) replacement is a Holley HP EFI. I am dreading replacing this because I had integrated the wiring and ECU for the C950 into the car and disassembling the plenum to remove the wiring is a major pain. And, the HP EFI with all the stuff needed (dual synch dist., CD ignition) is pushing $3000.

This will definitely push everything back that is not related to getting the car running. But, if I can get it running, perhaps I will be motivated to finish the rest this coming winter.

Will I ever get this car on the road?
 

BBShark

Garage Monkey
Staff member
Joined
Mar 5, 2008
Messages
4,621
Location
Right here
If it makes you feel better, I have a Holley Commander that's been sitting on my shelf for nearly that amount time as well.

I'll say this from the get go, I think Holley makes a great system, but I also think they have the worst tech/customer service of EFI company.

I was just talking to some people at Optima, FiTech is sponsoring them controlling a LS3 (I call it this for convenience). I'm using FiTech on my C3, and I plan on pulling the injectors from the housing along with the computer and wiring to run a port injection system... since they sponsor, maybe you can try them for free... you certainly bring an amazing build to them and have the racing chops that fit well within their marketing strategy....

I also like DIY tune and Megasquirt for much the same reason except I don't know of anyone they sponsor.


I think there are a lot of people with C950 systems sitting somewhere. I should have given up on it 10 years ago when I:
  • Found lots of mistakes in the installation manual (installation and wiring).
  • Holley quit supporting it (2007) and told people to upgrade (buy) a replacement.
  • Holley continued to sell these after 2007. No mention that you were on your own and it was a POS.

So it's going to be difficult to fork out $3000 for a "new" version knowing they could do the same thing again.

I'll take a look at the other offerings. One of my problems is that I built this motor with basically Ramjet 502 specs. That was basically all early 90's TPI sensors, ignition and throttlebody. Holley seems to be the only support for this because it is the same setup as their Stealth Ram.
 

BBShark

Garage Monkey
Staff member
Joined
Mar 5, 2008
Messages
4,621
Location
Right here
I finally pulled the trigger on all the stuff I need to replace the old C950 EFI "system". Holley HP EFI, Holley Dual Sync Dist., BBK Dual 58mm Throttle Body and Summit CD ignition.

I have been super busy with just about everything else but I would like to get this installed and running in the next month.

Wish me luck!

460f1ef51be4da.jpg
 

BBShark

Garage Monkey
Staff member
Joined
Mar 5, 2008
Messages
4,621
Location
Right here
Started removing the C950 from the car this weekend. I was successful at removing the ECU and the harness in the interior of the car. It was a not fun at all. When I put it in, the car had no interior and I integrated the wiring into the main harness for the car including wire looms and clamps all over the place! So this took a fair amount of time cutting it out without accidentally cutting wires that were part of the main harness (like diffusing a bomb).

Did I mention how much I hate wiring?

So next is taking the plenum apart to get to that wiring. Hoping that will go a little smoother.

Garbage:
461070b2423fd1.jpg
 

BBShark

Garage Monkey
Staff member
Joined
Mar 5, 2008
Messages
4,621
Location
Right here
Time has been limited for a while to weekends. I got the plenum taken apart today to expose the injector and sensor wiring. When I put this together, I put the wiring in down in the intake valley and then put the fuel lines on top of it. Big mistake. Ended up cutting the harness out with just about every cutter I have.

So the deconstruction of the C950 crap is done!


START
45f69201a68f85.jpg

WITH WIRING
4612a9869285e7.jpg

WITHOUT WIRING
4612a98d2898f1.jpg
 

BBShark

Garage Monkey
Staff member
Joined
Mar 5, 2008
Messages
4,621
Location
Right here
Finally completed the HP EFI wiring. I had the old ECU inside the car but there was no way to get the new ECU in there. Holley says this is ok for underhood but options were limited there. I removed the vacuum tank so that was pretty much the only space I could find. But, at this point access to that area is pretty limited.

This is mounted to the splash shield behind the wheel well. Been so long since I removed it, I couldn't remember what it was. But, the harness was long enough and, if I need to remove it, I can drop it out from the bottom. And a bonus, I can get to it through the side gills.

46163f79306458.jpg

46164b58e103d3.jpg
 

BBShark

Garage Monkey
Staff member
Joined
Mar 5, 2008
Messages
4,621
Location
Right here
So, I finally got all the Holley EFI stuff installed and setup. The setup was not too bad but some of the instructions are outdated (all manuals are for version 2 and I have version 5). Holley saves money by not printing or updating the manual and putting it online.

Last night I started it up and adjusted the TPS and IAC and it seems to run well. Next step is to drive the car in "learn" mode. Only problem is I have to install the springs and shocks to make it drivable.

I ended up not using the BBK throttle body. Lots of issues with that.

Baby steps!
 

BBShark

Garage Monkey
Staff member
Joined
Mar 5, 2008
Messages
4,621
Location
Right here
Uh-oh. Started the car to do some tuning and it wasn't running right. Rough idle, etc. I tried to adjust the IAC but I was doing it blind because you don't see sensor values until temp reaches 160 (Holley HP EFI). So eventually the car stalled an wouldn't re-start.

I check for spark-OK. Checked the fuel rail for pressure and got 8psi! Looks like I found a new project.

Good news is that I got the rear spring in. So, one step forward and one step back.
 
Top