Go Back   VetteMOD.com > VetteMOD Technical Discussion > EFI

Reply
 
Thread Tools
  #1  
Old 11-05-2018, 08:56 PM
BBShark's Avatar
BBShark BBShark is offline
United States | Garage Monkey
 
Join Date: Mar 2008
Location: Right here
Posts: 4,348
My Photos: (264)
Default Purging Air Out of Fuel Lines, Well That Was a Suprise

I Thought I would check my fuel lines for leaks before I put the body on it. Fuel lines, fuel rail regulator are all new. So, I disconnected the return line at the tank and ran the pump on a power supply. I had a gauge on the fuel rail.

Turned the pump on and saw pressure on the rail, went back to the tank and looked at the return line and nothing was coming out. I ran the pump for about two minutes, still no gas. I did think maybe the return flow would take a while but also started thinking, did I plumb the regulator correctly (it's been a while since I did it).

Long story short, I continued to run the pump and finnally got a trickle of fuel at the return. I have run these pumps without a regulator and the pump like a mini fire hose, The advertising for these would make you think they still pump at pressure. Not so, lesson learned.
__________________
Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 10:53 AM.
 


Design by: vBulletin Skins Zone
Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.